The problem appears to have been resolved and the mail queues are decreasing. We will continue to monitor the situation.
Posted Sep 04, 2026 - 15:50 CEST
Update
The problem appears to have been resolved and the mail queues are decreasing. We will continue to monitor the situation.
Posted Sep 04, 2026 - 15:06 CEST
Monitoring
We are aware that some customers may experience delays when sending and receiving emails to and from Microsoft recipients. This is due to a delivery issue on Microsoft's end, specifically Exchange Online Protection throttling and server busy errors. This is not an issue on our platform.
We are actively monitoring the situation and will provide updates as more information becomes available.